Link Search Menu Expand Document

Core Switch Configuration

user %USERNAME% group administrators password plaintext %PASSWORD% 
!
banner motd $
**********************************************************
NOTICE TO USERS
This is a private computer system and is the property of <YOUR ORGNIZATION NAME>. It is for authorized use only. users (authorized or unauthorized) have no explicit or implicit expectation of privacy while connected to this system.

Any or all uses of this system and all files on this system may be intercepted, monitored, recorded, copied, audited, inspected, and disclosed to an authorized site, Aruba networks, and law enforcement personnel (foreign and domestic).

By using this system, the user consents to such interception, monitoring, recording, copying, auditing, inspection, and disclosure at the discretion of an authorized site or <YOUR ORGNIZATION NAME> personnel.

Unauthorized or improper use of this system may result in administrative disciplinary action and civil and criminal
penalties. By continuing to use of this system you indicate your awareness of and consent to these terms and conditions of use. LOG OFF IMMEDIATELY if you do not agree to the conditions stated in this warning.
***********************************************************
$
!
ntp server %NTP_IP_Address% iburst version 3
!
ip dns host %DNS_IP%
ip dns domain-name %Domain_NAME% 
!
tacacs-server host %TACACS_SERVER_IP% key Plaintext %TACACS_KEY%
tacacs-server host %TACACS_SERVER_IP% key Plaintext %TACACS_KEY%
!
aaa group server tacacs %TACACS_SERVER_GROUP_NAME%
    server %TACACS_SERVER_IP%
    server %TACACS_SERVER_IP%
!
   aaa authentication login ssh group %TACACS_SERVER_GROUP_NAME% local
   aaa authentication login console group %TACACS_SERVER_GROUP_NAME% local
   aaa authorization commands default group local %TACACS_SERVER_GROUP_NAME% 
   aaa accounting all default start-stop group %TACACS_SERVER_GROUP_NAME% local
   aaa authentication allow-fail-through
!
tacacs-server tracking user-name USERNAME plaintext %TRACK_USER_PASSWORD%
!
Router ospf %OSPF_PROCESS_ID% area %OSPF_AREA_ID%
  passive-interface default
  router-id %COR1_LOOPBACK_IP%
  graceful-restart restart-interval 30
!
Interface 1/1/1
  description CORE_TO_AGG1
  ip address %AGG1_PTP_IP%/30
  no shutdown
  no ip ospf passive
  ip ospf network point-to-point
  ip ospf %OSPF_PROCESS_ID% area %OSPF_AREA_ID%
  ip pim-sparse enable
!
Interface loopback 0
  ip address %COR1_LOOPBACK_IP%/32
  ip pim-sparse enable
  ip ospf %OSPF_PROCESS_ID% area %OSPF_AREA_ID%
!
Interface loopback 1
  ip address %RP_ANYCAST_IP%/32
  ip pim-sparse enable
  ip ospf %OSPF_PROCESS_ID% area %OSPF_AREA_ID%
!
router pim
  enable
  rp-candidate source-ip-interface %RP_ANYCAST_IP%
  rp-candidate group-prefix %MULTICAST_SERVICE_SUBNET%/%MULTICAST_SERVICE_MASK%
  bsr-candidate source-ip-interface %RP_ANYCAST_IP%
  bsr-candidate priority 1
!
router msdp 
 enable 
 ip msdp peer %COR2_LOOPBACK_IP%
 connect-source loopback0

Back to top

© Copyright 2021 Hewlett Packard Enterprise Development LP. The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein. Aruba Networks and the Aruba logo are registered trademarks of Aruba Networks, Inc. Third-party trademarks mentioned are the property of their respective owners. To view the end-user software agreement, go to Aruba EULA.