Link Search Menu Expand Document

Data Center 1 Leaf 4 Configuration

!Version ArubaOS-CX GL.10.06.0113
!export-password: default
hostname 8325-DC1-L4
user admin group administrators password ciphertext AQBapfJeMnuC2wnWplwosB7CO0Uhj8Cw2t6Zd/E2RHppjVGXYgAAAIhR7CvpeNWRjxHc4yrcV3yrUfRMBkb4gLwiRq4mw07cyt9OK2k/vG4MM1No202ul1gKTXrsE79zNQDQ4jjD/pZibZ/GjxhusU/iyj33m2DQSkrEnMZF2dfsG/1mJNwXt3Zl
user afc_admin group administrators password ciphertext AQBapTQH7v2Rs5LeUNFxqe7eR0T7n3HBnUnBReJMpvYmtyDgYgAAAO7wYDOoYib6ZTmb7pbkxE0GWnmvisH/nXSE3datRW9p2Y28AToc7BHfp4wHDr0IsZiSEUKUOFjOJPsUWDl73DGBj9gLSwnNXHiOrKcMQMeBH4F/uHa13eGz20ubP6W3mGQ6
clock timezone america/aruba
bfd
vrf Overlay1
    rd 10.0.10.1:3
    route-target export 65000:101 evpn
    route-target import 65000:101 evpn
    address-family ipv4 unicast
        route-target export 65000:101
        route-target import 65000:101
    exit-address-family
vrf Overlay2
    rd 10.0.10.1:4
    route-target export 65000:102 evpn
    route-target import 65000:102 evpn
    address-family ipv4 unicast
        route-target export 65000:102
        route-target import 65000:102
    exit-address-family
ntp server 172.16.1.98 prefer
ntp server 172.16.1.99 prefer
ntp server pool.ntp.org minpoll 4 maxpoll 4 iburst
ntp enable
ntp vrf mgmt
cli-session
    timeout 0
!
!
!
ssh server vrf mgmt
system internal-vlan-range 3967-4094
vlan 1
vlan 100
    description AFC-created VLAN
vlan 200
    description AFC-created VLAN
vlan 3966
virtual-mac 02:00:00:00:02:00
evpn
    arp-suppression
    vlan 100
        rd auto
        route-target export 65000:10100
        route-target import 65000:10100
        redistribute host-route
    vlan 200
        rd auto
        route-target export 65000:10200
        route-target import 65000:10200
        redistribute host-route
interface mgmt
    no shutdown
    ip static 172.16.20.233/24
    default-gateway 172.16.20.1
interface lag 1 multi-chassis
    no shutdown
    description ESXi6 LAG
    no routing
    vlan trunk native 1
    vlan trunk allowed 1,100,200
    lacp mode active
    lacp fallback
    lacp rate slow
interface lag 2 multi-chassis                                  
    no shutdown
    description ESXi7 LAG
    no routing
    vlan trunk native 1
    vlan trunk allowed 1,100,200
    lacp mode active
    lacp fallback
    lacp rate slow
interface lag 256
    no shutdown
    description ISL
    no routing
    vlan trunk native 1
    vlan trunk allowed all
    lacp mode active
    lacp rate slow
    qos trust cos
interface 1/1/1
    no shutdown
    mtu 9198
    lag 1
interface 1/1/2
    no shutdown
    mtu 9198
    lag 1
interface 1/1/3
    no shutdown
    mtu 9198
    lag 2
interface 1/1/4
    no shutdown
    mtu 9198
    lag 2
interface 1/1/5
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/6
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/7
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/8
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/9
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/10
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/11
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/12
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/13
    no shutdown
    mtu 9198
    ip mtu 9198                                                
interface 1/1/14
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/15
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/16
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/17
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/18
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/19
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/20
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/21
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/22
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/23
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/24
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/25
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/26
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/27
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/28
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/29
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/30
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/31                                               
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/32
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/33
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/34
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/35
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/36
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/37
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/38
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/39
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/40
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/41
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/42
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/43
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/44
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/45
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/46
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/47
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/48
    no shutdown                                                
    mtu 9198
    ip mtu 9198
interface 1/1/49
    no shutdown
    mtu 9198
    qos trust cos
    description Keep alive Interface 8325-DC1-L4
    ip mtu 9198
    ip address 10.0.5.3/31
interface 1/1/50
    no shutdown
    mtu 9198
    lag 256
interface 1/1/51
    no shutdown
    mtu 9198
    lag 256
interface 1/1/52
    no shutdown
    mtu 9198
    lag 256
interface 1/1/53
    no shutdown
    mtu 9198
    qos trust cos
    description Leaf Spine RPI to 8325-DC1-S1
    ip mtu 9198
    ip address 172.18.105.17/31
    ip ospf 1 area 0.0.0.0
    ip ospf cost 1
    ip ospf network point-to-point
    ip ospf bfd
interface 1/1/54
    no shutdown
    mtu 9198
    qos trust cos
    description Leaf Spine RPI to 8325-DC1-S2
    ip mtu 9198
    ip address 172.18.105.25/31
    ip ospf 1 area 0.0.0.0
    ip ospf cost 1
    ip ospf network point-to-point
    ip ospf bfd
interface 1/1/55
    no shutdown
    mtu 9198
    qos trust cos
    description Leaf Spine RPI to 8325-DC1-S3
    ip mtu 9198
    ip address 172.18.105.9/31
    ip ospf 1 area 0.0.0.0
    ip ospf cost 1
    ip ospf network point-to-point
    ip ospf bfd
interface 1/1/56
    no shutdown
    mtu 9198
    ip mtu 9198
interface loopback 0
    description VSX Keepalive / OSPF / BGP underlay
    ip address 10.0.5.6/32
    ip ospf 1 area 0.0.0.0
interface loopback 1
    description VTEP source
    ip address 10.0.10.1/32
    ip ospf 1 area 0.0.0.0
interface vlan 100
    vrf attach Overlay1
    description Overlay #1 SVI VLAN100                         
    ip mtu 9198
    ip address 10.5.1.2/24
    active-gateway ip mac 02:00:10:05:01:01
    active-gateway ip 10.5.1.1
interface vlan 200
    vrf attach Overlay2
    description Overlay #2 SVI VLAN200
    ip mtu 9198
    ip address 10.5.2.2/24
    active-gateway ip mac 02:00:10:05:02:01
    active-gateway ip 10.5.2.1
interface vlan 3966
    description Transit VLAN
    ip mtu 9198
    ip address 10.0.5.12/31
    ip ospf 1 area 0.0.0.0
    ip ospf cost 1
    ip ospf network point-to-point
    ip ospf bfd
interface vxlan 1
    source ip 10.0.10.1
    no shutdown
    vni 10100
        vlan 100
    vni 10200
        vlan 200
    vni 100001
        vrf Overlay1 
        routing
    vni 100002
        vrf Overlay2 
        routing
vsx
    system-mac 02:00:00:00:01:00
    inter-switch-link lag 256
    role primary
    keepalive peer 10.0.5.2 source 10.0.5.3
    no split-recovery
    vsx-sync vsx-global
ip dns domain-name example.local vrf mgmt
ip dns server-address 172.16.1.98 vrf mgmt
ip dns server-address 172.16.1.99 vrf mgmt
!
!
!
!
!
router ospf 1
    router-id 10.0.5.6
    area 0.0.0.0
router bgp 65000
    bgp router-id 10.0.5.6
    bgp fast-external-fallover
    bgp bestpath as-path multipath-relax
    neighbor 10.0.5.1 remote-as 65001
    neighbor 10.0.5.1 ebgp-multihop 5
    neighbor 10.0.5.1 update-source loopback 0
    neighbor 10.0.5.7 remote-as 65001
    neighbor 10.0.5.7 ebgp-multihop 5
    neighbor 10.0.5.7 update-source loopback 0
    neighbor 10.0.5.11 remote-as 65001
    neighbor 10.0.5.11 ebgp-multihop 5
    neighbor 10.0.5.11 update-source loopback 0
    address-family ipv4 unicast
        redistribute connected
    exit-address-family
    address-family l2vpn evpn
        neighbor 10.0.5.1 activate
        neighbor 10.0.5.1 allowas-in 1                         
        neighbor 10.0.5.1 send-community extended
        neighbor 10.0.5.7 activate
        neighbor 10.0.5.7 allowas-in 1
        neighbor 10.0.5.7 send-community extended
        neighbor 10.0.5.11 activate
        neighbor 10.0.5.11 allowas-in 1
        neighbor 10.0.5.11 send-community extended
    exit-address-family
!
    vrf Overlay1
        bgp router-id 10.0.5.6
        address-family ipv4 unicast
            redistribute connected
        exit-address-family
!
    vrf Overlay2
        bgp router-id 10.0.5.6
        address-family ipv4 unicast
            redistribute connected
        exit-address-family
!
https-server vrf mgmt

Back to top

© Copyright 2021 Hewlett Packard Enterprise Development LP. The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein. Aruba Networks and the Aruba logo are registered trademarks of Aruba Networks, Inc. Third-party trademarks mentioned are the property of their respective owners. To view the end-user software agreement, go to Aruba EULA.