Link Search Menu Expand Document
calendar_month 11-Apr-24

Multifabric: Fabric 2 Leaf 2 Configuration

!
!Version ArubaOS-CX LL.10.11.1050
!export-password: default
hostname RSVCO-FB2-LF2
user admin group administrators password ciphertext AQBapaq8IznRqyAc4eikJ0Sa3rZp636mGoGErt4MkAKo72PRYgAAAFpLh5t9ag71ZpAGKv6vk0WoyMqaYm4ML4ODfNaEUI41hg0/wUzbNz2cJdf/9a1nE23hg4YRWL0J3S8Rb9O/rN2SNYSlX1+eFELG22ckMOb4P0c/b731wUdGi0oeMsOA3Y2z
user afc_admin group administrators password ciphertext AQBapbKvKuCKuJHyXeydNdM4xKa+NhUP+sYfq9ycz/vOtYA8YgAAACfixhSr9uH1tr433HG38lblz+SgJqUCbHu0ttnTTXFgIQ8pbQRRHnYtiZESzcnXSc9e8Pv+OnNghUWyw/eM4DjjfWvPRfEWp3AUtj70fdP8AInaVtX6LREA1MMonJCKBI0/
clock timezone america/los_angeles
bfd
profile aggregation-leaf
vrf PROD-DC-VRF
    rd 10.250.4.2:14
    route-target export 1:100001 evpn
    route-target export 65002:100001 evpn
    route-target import 1:100001 evpn
    route-target import 65002:100001 evpn
ntp server 10.2.120.98 prefer
ntp server 10.2.120.99 prefer
ntp enable
ntp vrf mgmt
cli-session
    timeout 0
!
!
!
!
!
!
ssh server vrf mgmt
vlan 1
vlan 101
    description AFC-created VLAN
vlan 102
    description AFC-created VLAN
virtual-mac 02:00:02:00:00:02
evpn
    arp-suppression
    vlan 101
        rd auto
        route-target export auto
        route-target export 1:10101
        route-target import auto
        route-target import 1:10101
        redistribute host-route
    vlan 102
        rd auto
        route-target export auto
        route-target export 1:10102
        route-target import auto
        route-target import 1:10102
        redistribute host-route
interface mgmt
    no shutdown
    ip dhcp
interface 1/1/1
    no shutdown
    mtu 9198
    no routing
    vlan trunk native 1
    vlan trunk allowed 101-102
interface 1/1/2
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/3
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/4
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/5
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/6
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/7
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/8
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/9
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/10
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/11
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/12
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/13
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/14
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/15
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/16
    no shutdown
    mtu 9198
    ip mtu 9198
interface 1/1/17
    description Leaf Spine RPI to RSVCO-FB2-SP1
    no shutdown
    mtu 9198
    ip mtu 9198
    ip address 10.255.4.5/31
    ip ospf 1 area 0.0.0.0
    no ip ospf passive
    ip ospf network point-to-point
interface 1/1/18
    description Leaf Spine RPI to RSVCO-FB2-SP2
    no shutdown
    mtu 9198
    ip mtu 9198
    ip address 10.255.4.13/31
    ip ospf 1 area 0.0.0.0
    no ip ospf passive
    ip ospf network point-to-point
interface loopback 0
    description BGP/OSPF underlay
    ip address 10.250.3.6/32
interface loopback 1
    description BGP VXLAN overlay
    ip address 10.250.4.2/32
interface vlan 101
    description Production web app SVI/VLAN 101 in DC overlay
    vrf attach PROD-DC-VRF
    ip mtu 9198
    ip address 10.5.101.1/24
    active-gateway ip mac 02:00:0a:05:00:01
    active-gateway ip 10.5.101.1
interface vlan 102
    description Production database SVI/VLAN 102 DC overlay
    vrf attach PROD-DC-VRF
    ip mtu 9198
    ip address 10.5.102.1/24
    active-gateway ip mac 02:00:0a:05:00:01
    active-gateway ip 10.5.102.1
interface vxlan 1
    source ip 10.250.4.2
    no shutdown
    vni 10101
        vlan 101
    vni 10102
        vlan 102
    vni 100001
        vrf PROD-DC-VRF 
        routing
ip dns domain-name example.local vrf mgmt
ip dns server-address 10.2.120.98 vrf mgmt
ip dns server-address 10.2.120.99 vrf mgmt
!
!
!
!
route-map connected-ospf permit seq 10
     set tag 1000
!
router ospf 1
    router-id 10.250.3.6
    max-metric router-lsa include-stub on-startup 300
    passive-interface default
    maximum-paths 8
    redistribute local loopback route-map connected-ospf
    area 0.0.0.0
router bgp 65002
    bgp router-id 10.250.3.6
    maximum-paths 8
    bgp log-neighbor-changes
    bgp deterministic-med
    bgp always-compare-med
    bgp bestpath as-path multipath-relax
    neighbor RSVCO-FB2-RR peer-group
    neighbor RSVCO-FB2-RR remote-as 65002
    neighbor RSVCO-FB2-RR description Spine and RR peer-group
    neighbor RSVCO-FB2-RR fall-over
    neighbor RSVCO-FB2-RR update-source loopback 0
    neighbor 10.250.3.2 peer-group RSVCO-FB2-RR
    neighbor 10.250.3.3 peer-group RSVCO-FB2-RR
    address-family ipv4 unicast
        redistribute connected
    exit-address-family
    address-family l2vpn evpn
        neighbor RSVCO-FB2-RR send-community both
        neighbor 10.250.3.2 activate
        neighbor 10.250.3.3 activate
    exit-address-family
!
    vrf PROD-DC-VRF
        bgp router-id 10.250.3.6
        maximum-paths 8
        bgp log-neighbor-changes
        bgp deterministic-med
        bgp always-compare-med
        bgp bestpath as-path multipath-relax
        address-family ipv4 unicast
            redistribute connected
        exit-address-family
!
https-server vrf mgmt

Back to top

© Copyright 2024 Hewlett Packard Enterprise Development LP. The information contained herein is subject to change without notice. The only warranties for Hewlett Packard Enterprise products and services are set forth in the express warranty statements accompanying such products and services. Nothing herein should be construed as constituting an additional warranty. Hewlett Packard Enterprise shall not be liable for technical or editorial errors or omissions contained herein. Aruba Networks and the Aruba logo are registered trademarks of Aruba Networks, Inc. Third-party trademarks mentioned are the property of their respective owners. To view the end-user software agreement, go to Aruba EULA.